Register Forum Rules Recent Forum Posts View Members Advanced Search
Current Time in Hong Kong (GMT+8):
Current Hong Kong Game Version: 1.57.54 (Released: May 16)
Character List
Guild List

April 29th, 2013
i redownloaded the game twice to try and fix this problem, everytime i hit the dbo icon then press start nothing comes up the launcher works fine just when i hit start nothing comes up?? can anyone plz help me??? or know whats going on?? its not my anti virus
April 29th, 2013
How did it start?
April 29th, 2013
Update your computer >.>
April 29th, 2013
Update your computer >.>

do you mean windows update?

Update your computer >.>

that didnt work its still not working

Last edited on April 29th, 2013 at 10:03 PM. Reason: Double Post
April 29th, 2013
try reinstalling the game again and browse the threads for manually updating the game someone made a
great tutorial on how to do it if you have any problems feel free to PM me
May 18th, 2013
Actually, same thing happened to me until I right-clicked and told it to RUN AS ADMIN. Try that. I had the same rpoblem and it fixed it for me.

My problem is, WHEN I DO get the game running, it REFUSES to allow me to log into my account(s). I -SUCCESSFULLY- (website said so) created MORE THAN ONE account, but the D*** game wont let me log in. It gives me some error message, first in gold, then below it, a LOOONG message in RED. For some reason, it seems like the website makes the accounts, then they dont exist. I cant RECREATE the accounts, 'cuz the site says they already exist. THEN WTF? Right?

WOULD SOMEONE PLEASE for the LOVE of DBZ, FOR THE LOVE OF YOUR FELLOW MAN, please either help me or just make a brand new account THAT WILL LET YOU LOG IN then email me the log in infos? I cant take this anymore. I had an account several months ago, got a new PC, reinstalled and got everything working, then BAM. DBO is like "Ha ha, there's no mention of this problem online. You know why? You did nothing 'wrong' were just personally screwing YOU."

So if I followed EVERY tutorial I can find, if the website says it MADE the accounts, WHY CANT I LOG INTO ANY OF THEM from the game????????? S O M E O N E please help
Thread Tools